Filter and Sort Issues (May 5, 2021 Incident)
Incident Report for Airtable
Resolved
This incident has been resolved.
Posted May 06, 2021 - 00:50 UTC
Monitoring
We have implemented a fix and our filtering and sorting features should be working normally. We're monitoring the results.
Posted May 05, 2021 - 21:55 UTC
Investigating
We've received reports from customers who are experiencing problems with Airtable's filtering and sorting features. We're investigating the cause of this issue and are working to resolve it as soon as possible. We apologize for the inconvenience.
Posted May 05, 2021 - 21:30 UTC