The issue appears to be caused by network connectivity between internet providers in APAC region. Customers affected can use a VPN to connect to airtable.com.
Posted Sep 10, 2024 - 02:42 UTC
Monitoring
The issue appears to be caused by network connectivity between internet providers in APAC. Customer affected can use a VPN to connect to airtable.com.
Posted Sep 10, 2024 - 02:35 UTC
Investigating
We are investigating reports that some customers in asia-pacific have difficulty accessing airtable.com.