Incident - 03/30/23
Incident Report for Airtable
Resolved
This incident is resolved and Airtable is functioning normally. Thanks for your patience.
Posted Mar 30, 2023 - 19:58 UTC
Identified
Some customers are experiencing failures when loading views with large amounts of data. We are implementing a fix and apologize for the inconvenience.
Posted Mar 30, 2023 - 19:50 UTC
This incident affected: Airtable Service.