Our recovery is complete, and Airtable's service is back to normal.
Posted Feb 21, 2026 - 01:27 UTC
Monitoring
We have completed the recovery of the primary issue. The vast majority of Airtable functionality is restored. There may be some residual slowness and errors.
Posted Feb 21, 2026 - 01:20 UTC
Update
Many Airtable bases are now reachable. Some bases and some Airtable features are still broken. We continue to work towards full recovery.
Posted Feb 20, 2026 - 23:16 UTC
Update
Recovery is continuing. We are on a path to full recovery and are exploring ways to expedite this.
Posted Feb 20, 2026 - 21:59 UTC
Update
We have begun recovery. Our remediation is still in progress. Some Airtable bases are reachable, and the rest will come online soon.
Posted Feb 20, 2026 - 20:56 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 20, 2026 - 19:12 UTC
Investigating
We are aware of an issue impact the availability of the Airtable service. Our engineers are engaged and we will post status updates here.