Some Bases Not Loading

Incident Report for Airtable

Resolved

We have resolved this incident, and Airtable is operating normally again. We deeply apologize for the inconvenience.
Posted May 16, 2025 - 20:20 UTC

Identified

We have identified the issue and are implementing mitigations
Posted May 16, 2025 - 19:57 UTC

Investigating

Some customers are having issues loading bases and other Airtable pages. Airtable engineering is investigating.
Posted May 16, 2025 - 19:48 UTC
This incident affected: Airtable Service.