Partial unavailability of Airtable 2026-02-12

Incident Report for Airtable

Resolved

We have mitigated the issue as of 10:22 PM PST and all site functionality except billing management should now be working. We are separately working on restoring billing functionality.
Posted Feb 13, 2026 - 07:49 UTC

Update

We have found the root cause and applied a mitigation that restores most base functionality such as read/writes as of 9:45PM PST.  However, certain functionality like adding collaborators/shares or creating/deleting applications are still unavailable. We're actively working on restoring that functionality.
Posted Feb 13, 2026 - 06:33 UTC

Investigating

We are currently investigating partial unavailability of Airtable
Posted Feb 13, 2026 - 05:40 UTC
This incident affected: Airtable Service.