Airtable is partially unavailable

Incident Report for Airtable

Resolved

Airtable's systems are back to normal, and this incident is resolved.
Posted Oct 21, 2025 - 16:51 UTC

Update

Airtable is operational and functioning within normal boundaries. Our engineering team will continue to monitor our systems, and we will share an update tomorrow morning PDT.
Posted Oct 21, 2025 - 00:03 UTC

Monitoring

Airtable's availability and latency have returned to normal. We are no longer observing networking issues with our infrastructure provider. We will continue to monitor for further disruptions as our provider rolls out further mitigations.
Posted Oct 20, 2025 - 20:06 UTC

Investigating

Airtable is experiencing a further degradation in performance and increased error rates. We suspect that our infrastructure provider is experiencing a networking issue.
Posted Oct 20, 2025 - 19:02 UTC

Update

Airtable is operational but certain features may experience degraded performance. We are working with our infrastructure provider to address capacity constraints.
Posted Oct 20, 2025 - 14:35 UTC

Monitoring

The underlying issue has been resolved and we are actively monitoring the service recovery.
Posted Oct 20, 2025 - 11:34 UTC

Identified

We have identified the issue with our infrastructure provider and are working with the provider to restore full functionality.
Posted Oct 20, 2025 - 09:01 UTC

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 08:59 UTC

Investigating

Airtable is partially unavailable due to an underlying service outage. Our engineering team is investigating and working to bring the service back to a healthy state.
Posted Oct 20, 2025 - 07:25 UTC
This incident affected: Airtable Service.