We have resolved this incident, and Airtable’s services are functioning normally since 10:53am PT. We’re sorry for the inconvenience to our customers’ operations.
Posted 2 years ago. Apr 27, 2023 - 01:09 UTC
Monitoring
We have implemented a fix to get Airtable’s services back up and running 10:53am PT, and we are monitoring the results. Customers should have no issues while accessing Airtable. We deeply apologize for the disruption.
Posted 2 years ago. Apr 26, 2023 - 18:25 UTC
Investigating
Airtable’s services are currently unavailable. Our engineers are actively investigating this incident. We apologize for the inconvenience this has caused.