Incident - 06/20/23

Incident Report for Airtable

Resolved

We released a new desktop app version (1.6.2) which resolves this issue. For those using Airtable's desktop app, please update to the latest version and restart your app. Thanks for your patience.
Posted 2 years ago. Jun 20, 2023 - 23:00 UTC

Identified

We’ve identified an error that prevents people from downloading attachments in our desktop app, and a fix is being implemented soon. In the meantime, customers can use our browser client, which is functioning normally.
Posted 2 years ago. Jun 20, 2023 - 20:17 UTC
This incident affected: Airtable Service.