Airtable is partially unavailable

Incident Report for Airtable

Resolved

This incident has been resolved.
Posted Nov 20, 2025 - 19:34 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 20, 2025 - 18:49 UTC

Update

We are continuing to work on a fix for this issue.
Posted Nov 20, 2025 - 18:27 UTC

Identified

We are responding to an incident where fewer than 1% of bases are periodically experiencing increased errors and latency due to an underlying database issue. We have identified the issue and our engineering team is working to resolve this.
Posted Nov 20, 2025 - 18:26 UTC
This incident affected: Airtable Service.