Incident - 06/07/23

Incident Report for Airtable

Resolved

This incident is resolved. Thank you for patience.
Posted 2 years ago. Jun 07, 2023 - 19:58 UTC

Identified

Customers are experiencing continued disruptions in some Airtable services, and we're working to resolve these issues as quickly as possible.
Posted 2 years ago. Jun 07, 2023 - 16:47 UTC

Monitoring

Airtable's services have recovered, and we are monitoring to avoid further disruption. We will continue to keep you updated on our progress.
Posted 2 years ago. Jun 07, 2023 - 15:39 UTC

Investigating

Airtable’s services are currently unavailable for some customers. Our engineers are actively investigating this incident, and will keep you informed as updates are available. We apologize for the inconvenience.
Posted 2 years ago. Jun 07, 2023 - 15:16 UTC
This incident affected: Airtable Service.