MCP Server Unavailable

Incident Report for Airtable

Resolved

A fix has been implemented and the Airtable MCP server is now fully available. Please reach out to Airtable Support if you have any further questions.
Posted Mar 13, 2026 - 23:44 UTC

Update

We have validated the fix and are deploying it to production now.
Posted Mar 13, 2026 - 23:00 UTC

Update

We have prepared a fix and are currently validating it before deploying it to production.
Posted Mar 13, 2026 - 22:24 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 13, 2026 - 21:24 UTC

Investigating

We are aware that the Airtable MCP server is currently unavailable. Our engineers are investigating and we will post updates here as we have them.
Posted Mar 13, 2026 - 21:11 UTC
This incident affected: Airtable Service.