Incident
Incident Report for Airtable
Resolved
All Airtable services are now fully back to normal. We apologize for any disruption caused by this incident, and greatly appreciate your patience.
Posted Jan 22, 2021 - 23:06 UTC
Monitoring
Airtable services are back up. We are still investigating and monitoring the situation closely. Thank you for your patience, and we sincerely apologize for the inconvenience.
Posted Jan 22, 2021 - 20:20 UTC
Investigating
Airtable is currently experiencing downtime. Our engineers are actively investigating the issue, and we’ll have more updates as soon as possible.
Posted Jan 22, 2021 - 19:51 UTC