Incident

Incident Report for Airtable

Resolved

Airtable services are now back to normal. Thank you for your patience.
Posted 4 years ago. Feb 10, 2021 - 17:51 UTC

Investigating

Airtable is currently experiencing downtime. Our engineers are actively investigating the issue, and we’ll have more updates as soon as possible.
Posted 4 years ago. Feb 10, 2021 - 17:17 UTC