Incident - 5/27/2024

Incident Report for Airtable

Resolved

This incident has been resolved.
Posted May 27, 2024 - 18:44 UTC

Monitoring

Our email sending infrastructure is experiencing issues, which is leading to failures on some product surfaces. We are continuing to monitor the situation. We’re sorry for the inconvenience to our customers’ operations.
Posted May 27, 2024 - 15:37 UTC
This incident affected: Airtable Service.