Non-logged-in users unable to upload attachments to forms

Incident Report for Airtable

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 12, 2026 - 21:28 UTC

Identified

We are aware of an issue impacting non-logged-in users from being able to upload attachments to standalone forms. Our engineers have identified the root cause, and we expect to resolve the issue within the next few hours.
Posted Feb 12, 2026 - 17:29 UTC
This incident affects: Airtable Service.