Small percentage of bases experiencing slow loading
Incident Report for Airtable
Resolved
This incident has been resolved.
Posted Sep 02, 2024 - 15:53 UTC
Identified
We are aware of an issue that is causing slow loading and other issues with a very small percentage of bases. Our engineers have identified the root cause of the issue and are working on a remediation.
Posted Sep 02, 2024 - 15:20 UTC