Service interruption on Airtable iOS app

Incident Report for Airtable

Resolved

This issue has been fully resolved now.
Posted Apr 16, 2026 - 19:38 UTC

Monitoring

We have identified the problem and started the recovery.
Posted Apr 16, 2026 - 19:28 UTC

Investigating

We are seeing issues with Airtable iOS app, our engineering team is investigating the problem.
Posted Apr 16, 2026 - 18:54 UTC
This incident affected: Airtable Service.