Airtable down - July 18, 2023
Incident Report for Airtable
Resolved
We have resolved this incident, and Airtable’s services are functioning normally. We’re sorry for the inconvenience to our customers’ operations.
Posted Jul 18, 2023 - 19:18 UTC
Identified
We have identified the issue and our services are recovering. We appreciate your continued patience and will continue to keep this page updated with progress.
Posted Jul 18, 2023 - 19:03 UTC
Investigating
Airtable’s services are currently unavailable. Our engineers are actively investigating this incident. We apologize for the inconvenience this has caused.
Posted Jul 18, 2023 - 18:33 UTC
This incident affected: Airtable Service.