Incident 03/12/21
Incident Report for Airtable
Resolved
This incident has been resolved.
Posted Mar 12, 2021 - 22:36 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 12, 2021 - 21:48 UTC
Investigating
Airtable is currently experiencing downtime. Our engineers are actively investigating the issue, and we’ll have more updates as soon as possible.
Posted Mar 12, 2021 - 21:22 UTC